服务器压力测试结果(LoadRunner压力测试结果分析探讨)

本文目录
LoadRunner压力测试结果分析探讨
分析原则:
1. 具体问题具体分析(这是由于不同的应用系统,不同的测试目的,不同的性能关注点)
2. 查找瓶颈时按以下顺序,由易到难。
服务器硬件瓶颈 网络瓶颈(对局域网,可以不考虑) 服务器操作系统瓶颈(参数配置) 中间件瓶颈(参数配置,数据库,web服务器等) 应用瓶颈(SQL语句、数据库设计、业务逻辑、算法等)
分析的信息来源:
1. 根据场景运行过程中的错误提示信息
2. 根据测试结果收集到的监控指标数据
一.错误提示分析
分析实例:
1.Error: Failed to connect to server “172.17.7.230″: Connection
Error: timed out Error: Server “172.17.7.230″ has shut down the connection prematurely
分析:
A、应用服务死掉。
(小用户时:程序上的问题。程序上处理数据库的问题,实际测试中多半是服务器链接的配置问题)
B、应用服务没有死
(应用服务参数设置问题)
对应的Apache和tomcat的最大链接数需要修改,如果连接时收到connection refused消息,说明应提高相应的服务器最大连接的设置,增加幅度要根据实际情况和服务器硬件的情况来定,建议每次增加25%!
C、数据库的连接
(数据库启动的最大连接数(跟硬件的内存有关))
D、我们的应用程序spring控制的最大链接数太低
2. Error: Page download timeout (120 seconds) has expired
分析:
A、应用服务参数设置太大导致服务器的瓶颈
B、页面中图片太多
C、在程序处理表的时候检查字段太大多
D、实际测试时有些资源需要请求外网,而我们的测试环境是局域网环境
3. Error “
分析:
A、脚本设计错误,造成页面异常。服务器有响应!
B、并发数过大,造成服务器响应延迟。
4. Error page “text=xxxxx”
分析:
A、脚本设计问题,例如,前一脚本修改了某些内容,造成后面的脚本访问异常。
B、不确定因素,有时候回放正常的脚本,一放到场景中就出现这样的错误。只能反复修改脚本!
二.监控指标数据分析
1.Vusers数
Loadrunner 系统设置的虚拟用户数目。Vuser去实际调用事先制作的脚本文件中的应用。
每个Vuser产生响应的操作,所有的操作对服务器形成并发。
颜色 比例 度量 图最小值 图平均值 图最大值 图中间值 图SD
1 Run 0.0 21.25 44 41 21.276
在实际测试中,Vusers可以根据实际情况的需要,在测试过程中增加或者减少。
2.最大并发用户数:
颜色 比例 度量 最小值 平均值 最大值 SD
100 Apache CPU 使用情况(Apache):172.17.7.210 0.777 0.852 0.93 0.043
0.01 已发送 KB/秒(Apache):172.17.7.210 6 1430.371 2689.333 327.924
0.1 点击次数/秒(Apache):172.17.7.210 0.333 114.352 533.667 40.201
应用系统在当前环境下能承受的最大并发用户数。
在方案运行中,如果出现了大批用户的业务操作失败,或出现了服务器shutdown的情况,则说明在当前环境下,系统承受不了当前并发用户的负载压力,那么最大并发用户数就是前一个没有出现这种现象的并发用户数。
从上图可以看出:在测试运行到4个小时左右的时候,apache的点击数/秒开始迅速增加!
3.业务操作响应时间:
使用“事务性能摘要”图,可以确定在方案执行期间响应时间过长的事务。
颜色 比例 度量
1 最小值
1 平均值
1 最大值
分析事务的响应情况,要每次详细分析,目前还只能观察到响应时间过长的事务!
4.每秒点击数
负载测试期间每秒内 Vuser 在 Web 服务器上点击的次数。可根据点击次数来估算 Vuser 生成的负载数。
颜色 比例 度量 图最小值 平均值 图最大值 图中间值 图SD
1 点击次数 69.908 105.736 130.244 103.666 12.186
从图中不难看出,在4小时的时候,点技数明显增高。和apache的每秒点击数增大的时间相吻合!
5.吞吐量
负载测试期间 Web 服务器上的吞吐量(字节)。吞吐量表示在任何指定秒内 Vuser 从服务器接收到的数据量。此图可估计 Vuser 生成的负载量(服务器吞吐量)。
颜色 比例 度量 图最小值 平均值 图最大值 图中间值 图SD
1 Throughput 1257502.795 1375591.372 1525865.047 1372743.691 49130.473
同样,从图中可以看出,在4个小时的时候,web服务器的吞吐量开始增高。
在图中还可以看到吞吐量的走势图,从开始到进行到4个小时反弹之前呈降低的趋势,这是因为系统在初期调用的资源都是直接来之服务器,运行一段时间后系统的部分资源来自缓存。
6.下载组件大小
每个页面的组件大小,且包括组件的标头的大小!
页面组件大小的分析表格比较复杂,实际分析中可以通过loadrunner的报告分析工具来分析。页面组件大小分析主要是找到页面中比较庞大的组件,如果其影响到了页面的下载速度,则要想办法将其改小!
7.Apache资源
显示APACHE web服务器上的资源摘要。前面已经提到过以并发点击数为主。
颜色 比例 度量 最小值 平均值 最大值 SD
100 Apache CPU 使用情况(Apache):172.17.7.210 0.777 0.852 0.93 0.043
0.01 已发送 KB/秒(Apache):172.17.7.210 6 1430.371 2689.333 327.924
0.1 点击次数/秒(Apache):172.17.7.210 0.333 114.352 533.667 40.201
三.服务器资源监控指标
(目前通过top监察)
内存:
Linux资源监控中指标内存页交换速率(Paging rate),如果该值偶尔走高,表明当时有线程竞争内存。如果持续很高,则内存可能是瓶颈。也可能是内存访问命中率低。
实际测试中,当并发点击数出现突然剧增前后,内存的PR 值则居高25不下。说明目前测试的系统中内存存在瓶颈!
内存资源成为系统性能的瓶颈的征兆:
很高的换页率(high pageout rate);
进程进入不活动状态;
交换区所有磁盘的活动次数可高;
可高的全局系统CPU利用率;
内存不够出错(out of memory errors)
处理器:
Linux资源监控中指标CPU占用率持续超过80%(对该值的要求,根据具体应用和机器配置而要求不同,有资料表明95%),表明瓶颈是CPU。
实际测试中,当并发点技数出现突然增加前后,cpu的占用率持续保持在86%以上!
说明,目前系统用应用的cpu也是测试的瓶颈!
CPU资源成为系统性能的瓶颈的征兆:
很慢的响应时间(slow response time)
CPU空闲时间为零(zero percent idle CPU)
过高的用户占用CPU时间(high percent user CPU)
过高的系统占用CPU时间(high percent system CPU)
长时间的有很长的运行进程队列(large run queue size sustained over time)
四.数据库服务器
数据库服务器目前测试观察,当web服务器点击率增大时,观察mysql数据库的最大连接数,仍未超过系统设置的最大连接数。所以,暂时未发现数据库的瓶颈!
五.结论
以上报告分析中的数据、图标均来自同一次测试。是在平时测试中挑出的一次现象比较明显,比较利于观察的作为分析案例。
根据以上综合分析,当前测试环境下,当应用系统产生最大533.667的并发压力。平均负载压力114.352。根据分析,用户在4个小时的时候,并发数迅速增加前后的值在400左右!分析结果跟实际测试的硬件环境以及测试脚本有一定关系。同时,测试服务器的硬件配置和实际服务器的配置还有一定的差距!
Jmeter 压力测试并输出HTML报告
在进行性能测试执行之前,需要进行场景的设计:
以什么方式启动,如何持续进行,直至测试结束
三部曲:启动---持续进行---结束
PS:一般情况下,建议限制Jmeter的的线程数在300及以内,这样能更好的发挥出jmeter的性能
测试步骤:
测试计划---线程组--HTTP请求---监听器---运行脚本---查看报告
PS:默认情况下,JMeter运行需要占用1 GB的内存,这可能还不够,取决于你的测试计划和需要运行的线程数
一个测试计划描述了一系列Jmeter运行时需要执行的步骤,可以包含一个或者多个线程组,逻辑控制器,取样发生控制,监听器,定时器,断言和配置元件。
启动JMeter,会出现一个空的测试计划,此次练习通过手写脚本来实现
(不熟悉操作的,也可以通过模板的形式创建,在菜单栏文件--Templates,下拉列表中选择Recording,点击Create,一个完整的Test Plan就生成了,当然我们可以删除不需要的内容)
作用:模拟用户个数、发送请求的频率及次数
PS:设置合理的线程数对能否达到测试目标有着决定性的影响,另外,设置合理的循环次数也很重要
此处添加3个HTTP请求
1、添加响应断言 :设置响应码为200
2、查看结果树,验证请求
调试时线程数和循环次数设为1就可以了,记得调试好之后再改回去
3、禁用查看结果树,命令行执行脚本
我们在启动Jmeter时就会看到命令行的提示信息,进行负载测试时请不要使用GUI模式,也就是用命令行模式运行 JMeter 测试脚本,这样可以大大缩减所需要的系统资源
备注:GUI 即图形用户界面模式,只应用于创建测试脚本、调试脚本
图中也给出了命令格式: jmeter -n -t ,JMeter 默认去当前目录寻找脚本文件,并把日志记录在当前目录,当然也可以使用绝对路径来执行
参数说明:
(1)直接生成HTML报告
PS:输出文件(-l后的文件)必须是不存在的,report文件夹为空文件夹或者不存在(-o后面的),不然无法生存报告
启动CMD窗口,输入以下命令:
jmeter -n -t C:\Users\zhangXXX\Desktop\baidu.jmx -l C:\Users\zhangXXX\Desktop\html.csv -e -o C:\Users\zhangXXX\Desktop\baidu-reports
(2)使用之前的测试结果,生成测试报告
启动CMD窗口,先生成测试结果,再生成报告,输入以下命令:
PS:-g 指定已存在的测试结果文件
以上两种方法,其实最终都依赖生成的测试报告。双击报告文件夹中的index.html就可以查看报告
Dashboard:
Test and Report informations:指的是测试和报告信息
APDEX(Application Performance Index):应用程序性能满意度的标准,范围在0-1之间,1表示达到所有用户均满意,越接近1满意度越高
Requests Summary:请求的通过率(OK)与失败率(KO),百分比显示
Statistics:数据分析,基本将Summary Report和Aggrerate Report的结果合并
Errors:错误情况,依据不同的错误类型,将所有错误结果展示
Charts: 用图表的形式展示测试数据,让测试报告更加直观**
主要有如下特点:
(1)将测试过程中经常使用的数据,用图表的形式展示,让测试结果更加直观
(2)每个图表数据,有两种展示形式
(3)支持请求样例过滤显示
(4)支持导出PNG图片格式
Over Time Charts:
Throughput Charts:
Response Times Charts:
4、添加所需监听器,导入日志文件即可查看
在性能测试过程中,我们往往需要将测试结果保存在一个文件当中,也可以为日后的性能测试报告提供更多的素材
在Jmeter中,结果都存放在 .jtl 文件中,格式有很多种,可以根据需要进行更爱,选择某个监听器,在 configure页面 进行相应配置,让我们来查看下保存后的文件有哪些内容:
接下来添加一个聚合报告,然后导入日志文件,查看结果,还可以添加其他的监听器,操作方法一样
PS:如果测试计划中增加了监听器(生成概要结果),在执行命令时就可以看到每个线程的执行情况
PS:设置好线程数、循环次数、集合点、事务、断言、关联等等后即可执行压力测试
原理和LR的agent差不多,因为jmeter由Java开发,耗内存、cpu,所以需要采用分布式
步骤:
1、关闭防火墙
2、在所要运行jmeter并作为负载生成器的机器上安装jmeter(确保在所有系统中使用了相同版本号的Jmeter和jdk)
PS:目标服务器需要在相同网段,确保Jmeter可以访问目标服务器
3、确定其中一台机器作为主controller,其他的机器作为agent,然后运行所有agent机器上的jmeter-server文件
4、在controller机器的jmeter中bin目录下,找到jmeter.properties文件,添加节点IP,修改localhost为压力机IP
5、启动conttoller机子上的jmeter应用,选择菜单【运行】---远程启动来分别启动agent,也可以直接选择【远程全部启动】来将所有个agent启动
在性能测试过程中,我们通常需要将测试结果保存在一个文件当中,既可以保存测试结果,也可以为日后的性能测试报告提供更多的素材
Jmeter中,结果都存放在.jtl文件,一般以csv文件格式记录,只需要选择某个监听器,点击页面的configure按钮,建议勾选如下项:Save Field Name,Save Assertion Failure Message
技术点:HTTP相关设置+参数化+断言+关联+简单控制器+查看结果树
关联:通过Json控件或正则表达式获取
(1)线程组建议替换为jp@gc - Stepping Thread Group,功能比线程组多很多
(2)可以加事务控制器
(3)查看结果树替换为聚合报告或类似的报告,如果还是想看查看结果树记得勾选仅日志错误(查看结果树打印的日志比较多,会影响性能)
(4)造数据
总结:
一个子系统建议放在同一个 “测试计划”中,流程测试可以通过“线程组”来区分,这样也便于设定不同的测试数据个数。
比较独立的接口,可以统一放在一个线程组内,顺序完成测试。
流程性接口的测试:如果要测试的接口可以组成一个流程,只需要顺序添加多个“HTTP 请求”的Sampler,各请求之间可以提取需要在上下文传递的数据作为参数,以保证流程中数据的一致性
使用jmeter在测试服务器上压测测试后,怎么根据测试结果评估/推测正式服务器能达到的处理能力
基本查看服务端性能常用命令:
cup各核使用率,内存使用情况: top 按1;
服务端网络带宽查看:sudo iftop -n
***隐藏网址***
***隐藏网址***
PS:jmeter的plugin1.4.0的只支持jmeter3.2以下,不包括3.2,
3.然后解压两个zip包,把jar文件拷贝到/lib/ext文件夹下,环境配置就完成了。
接下来实际运行一下:
1.直接运行ServerAgent-2.2.1文件夹下的startAgent.bat,启动监控
2.打开jmeter,新建线程组,设置循环下去的线程
监听器选择jp@gc - PerfMon Metrics Collector和jp@gc - Transactions per Second两个监听器,简单配置一下它们,配置要监听的IP和端口,ServerAgent默认是4444端口,当然你可以修改,比如:./startAgent.sh –udp-port 0 –tcp-port 3450这样。
将程序进行后台运行:
nohup java -jar -Ddubbo.protocol.port=9999 datetool-0.0.1-SNAPSHOT.jar &

更多文章:
网关是什么怎么设置(网关到底是什么,不同的网络如何正确设置网关)
2026年10月11日 08:30
亚洲和欧洲的分界线简图(画出亚欧,亚非,南北美,亚洲北美洲和南美南极的分界线和名称.图片)
2026年10月11日 05:50
虚拟空间免root大全(gameguardian修改器免root安卓APK下载地址)
2026年10月11日 00:10







