nagios core(Linux里面自动化部署工具有哪些)

:暂无数据 2026-09-07 17:30:11 :0

nagios core(Linux里面自动化部署工具有哪些)

其实nagios core的问题并不复杂,但是又很多的朋友都不太了解Linux里面自动化部署工具有哪些,因此呢,今天小编就来为大家分享nagios core的一些知识,希望可以帮助到大家,下面我们一起来看看这个问题的分析吧!

本文目录

Linux里面自动化部署工具有哪些

1. Puppet
Puppet是一款开源工具,旨在为系统管理员大大简化自动化和报告工作。它基本上是款配置管理软件,有助于配置和维护企业网络中的服务器及其他系统。系统管理员通常每天要花大量时间重复做同样的任务。他们总是想要使这些任务实现自动化,以便有更多的时间来处理其他项目或学习新的概念和脚本语言。管理员可以通过编写脚本使任务实现自动化,但是在拥有大型网络的公司,脚本不是很方便。这时候,Puppet就大有用场,因为借助Puppet,你可以:
为网络上的每个主机定义独特的配置设置;
不断监测网络,查找任何变动;
帮助高效地创建和管理用户;
帮助管理每个开源工具的配置设置。
2. CHEF
Chef是另一款可供Linux系统管理员使用的流行的自动化工具。它用Ruby和Erlang编写,对于配置和维护公司的服务器大有帮助,无论贵公司拥有十台服务器还是上百台。它还可以帮助你将云端服务器与亚马逊EC2、OpenStack、RackSpace或谷歌云整合起来。Chef可以将你的基础设施转变成代码,那样借助代码,你只要更改几行代码,就能轻松撤下一台服务器,从而让你轻松管理服务器。物理节点还意味着:将变更内容部署到生产环境之前,可以对它轻松进行测试,你还可以轻松控制针对代码的每次更新的版本。Chef DK为你提供了测试和管理配置的所有工具,Chef Server充当你所有“菜谱”(recipe)的存储库,可以管理与服务器连接的每个节点。Chef客户软件在每个客户端上运行,时不时收到服务器方面的信息,从而更新其配置设置。
3. CFEngine
面向Linux系统管理员的下一款自动化工具是CFEngine,这是另一个领先的自动化系统,可帮助你轻松管理整套基础设施,并使之实现自动化。一旦你使用CFEngine为网络中的系统定义了配置,那么CF Engine就会自动确保配置符合规范。不用说,如果你的网络中有10个或100个节点,可以在短短几秒内更新或改动任何一个节点或所有节点。CFEngine之所以受到许多Linux系统管理员的青睐,是由于它运行成本低、响应速度快、具有自愈合功能。
4. Ansible
Ansible是Red Hat提供的一款开源配置管理和IT企业自动化软件,随带一种简单的编程语言,让系统管理员能够高效地处理自动化和配置过程。Ansible由控制机器和控制机器控制的节点组成。节点是通过SSH来加以控制的。Ansible的主要特点之一是代理并不是部署到节点 ,但是完全借助SSH来进行通信。易学易用、具有一致性、高可靠性和安全性是让Ansible脱颖而出的其他特性。Ansible的唯一局限就是无法配置裸机和虚拟机。
5. Foreman
Foreman是另一种用于取证分析的开源配置管理工具。Foreman提供了仪表板,我们可以通过仪表板来配置裸机服务器和虚拟机。默认情况下,无论我们何时安装Foreman,它都使用Puppet作为配置工具。不过借助插件,Foreman还支持与其他配置管理工具整合起来,比如Chef、Puppet、Ansible、Salt及其他众多工具。Foreman自动化工具还随带各种各样的接口,包括命令行接口、Web前端以及REST API。Foreman的其他一些显著功能包括如下:
通过仪表板,管理Puppet模块和puppet类方面的改动;
很容易从Foreman仪表板来管理Puppet环境;
由于仪表板,创建主机群(Hosts Group)以及为主机群添加puppet模块变得很轻松;
可以从Foreman仪表板,轻松添加Puppet模块或推送到节点。
6. Katello
Katello是另一种开源自动化工具。换而言之,我们可以说Katello是一种开源版的Red Hat satellite Server;如果我们不想花钱在企业产品及其支持上,就可以用它来代替Red Hat satellite Server。Katello已被Foreman收购,Foreman中的大部分功能在Katello中也得到了支持。Katello Server的主要功能如下:
给基于Linux的服务器(RHEL和CentOS )打补丁;
使用Pulp Service来同步代码库;
使用Foreman进行各种配置;
它还可以处理订阅内容管理,并审计所有已部署的软件包;
借助Katello,你可以为所有主机创建主机群,另外还可以在单一主机或一群主机上批量执行操作。
7. Nagios
Nagios现在名为Nagios Core,它是一种开源自动化和监控工具,可以管理基础设施中的所有系统。它还提供警报服务,一旦察觉到你的网络中哪里有问题,就会提醒系统管理员。借助SNMP以及Nagios,系统管理员还可以控制并管理打印机、路由器和交换机。Nagios让我们得以创建事件处理工具,一旦某个应用程序及其服务停运,就可以自动重启出现故障的那个应用程序及其服务。

nagios core not running是怎么回事

我也遇到这样的问题,百度的结果应该是CGI脚本没开启的缘故,执行下面两步

sudo a2enmod cgi

sudo service apache2 restart

然后刷新网页。

Ambari 1.6 自动安装hadoop 2.2.0 在Ambari启动namenode时报错

lib/ambari-agent/data/, ’,587 - Modifying group nobody
2015-03-11 09;cache/:34:49;python2: False}
2015-03-11 09:34.env;var/scripts/site-packages/environment;ambari-agent/data/,511 - Group[’hadoop’/var/lib/ambari-agent/:
Traceback (most recent call last);lib/:34:48,348 - Error while executing command ’any’;, line 93,663 - Group {’ignore_failures’.6/conf doesn’t exist
Error;, ’/.py"2;command-413;ambari-agent/data//usr/lib/python2.6/site-packages/resource_management/core/python2;] {’]
stdout;var//usr/lib/python2.6/site-packages/resource_management/core/stacks/HDP/2.0.6/hooks/before-ANY/:34:48;, line 115, in run_action
provider_action()
File "/python2, parent directory /etc/hadoop/libraries/:
File "/conf/hadoop-env.py’;ambari-agent/data/.run()
File "lib/lib/:48,663 - Modifying group users
2015-03-11 09.py".6’errors-413.txt
2015-03-11 09:34:48;HDP/hooks/cache/structured-out-413.json’] {’/var/lib/ambari-agent/python2;, line 123, in execute
method(env)
File ".py".6/usr/resource_management/.resource, dirname))
Fail,你看看是否有遇到过.json’;stacks/HDP/2.0.6/hooks/before-ANY’var/resource_management/usr/site-packages/cache/ambari-agent/cache/stacks/, line 148, in __init__
self, ’var/resource_management/, ’/:34:48;shared_initialization, in action_create
raise Fail(", line 31, in hook
setup_hadoop_env()
File "before-ANY/scripts/hook.6/.0;output-413.txt
2015-03-11 09:34:48.sh’] failed;scripts/: /bin/usr/: False}
2015-03-11 09.py"ignore_failures’core/base: Applying File[’core/providers/system;site-packages/, ’/,512 - Adding group Group[’,谢谢。
stderr.py"var/:34:48;stacks/HDP/2.0.6/hooks/before-ANY/, line 149, in run
self.run_action(resource, action)
File ", line 113, in setup_hadoop_env
content=InlineTemplate(params.hadoop_env_sh_template)
File "/: /,737 - Group {’ignore_failures’: False}
2015-03-11 09:34:48,738 - Adding group Group
2015-03-11 09:34:48,810 - User}
2015-03-11 09:34:48,811 - Modifying user nobody
2015-03-11 09:34:48,885 - User}
2015-03-11 09:34:48,886 - Adding user User
2015-03-11 09:34:48,958 - User}
2015-03-11 09:34:48,958 - Adding user User
2015-03-11 09:34:49,027 - User}
2015-03-11 09:34:49,028 - Adding user User
2015-03-11 09:34:49,103 - User}
2015-03-11 09:34:49,104 - Adding user User
2015-03-11 09:34:49,177 - File {’content’: StaticFile(’changeToSecureUid.sh’), ’mode’: 0555}
2015-03-11 09:34:49,180 - Execute {’not_if’: ’test $(id -u ambari-qa) -gt 1000’}
2015-03-11 09:34:49,253 - Skipping Execute due to not_if
2015-03-11 09:34:49,254 - Directory {’owner’: ’root’, ’group’: ’root’, ’recursive’: True}
2015-03-11 09:34:49,255 - Link {’not_if’: ’ls /etc/hadoop/conf’, ’to’: ’/etc/hadoop/conf.empty’}
2015-03-11 09:34:49,328 - Skipping Link due to not_if
2015-03-11 09:34:49,348 - File {’content’: InlineTemplate(...), ’owner’: ’hdfs’}
2015-03-11 09:34:49,348 - Error while executing command ’any’:
Traceback (most recent call last):
File "/usr/lib/python2.6/site-packages/resource_management/libraries/script/script.py", line 123, in execute
method(env)
File "/var/lib/ambari-agent/cache/stacks/HDP/2.0.6/hooks/before-ANY/scripts/hook.py", line 31, in hook
setup_hadoop_env()
File "/var/lib/ambari-agent/cache/stacks/HDP/2.0.6/hooks/before-ANY/scripts/shared_initialization.py", line 113, in setup_hadoop_env
content=InlineTemplate(params.hadoop_env_sh_template)
File "/usr/lib/python2.6/site-packages/resource_management/core/base.py", line 148, in __init__
self.env.run()
File "/usr/lib/python2.6/site-packages/resource_management/core/environment.py", line 149, in run
self.run_action(resource, action)
File "/usr/lib/python2.6/site-packages/resource_management/core/environment.py", line 115, in run_action
provider_action()
File "/usr/lib/python2.6/site-packages/resource_management/core/providers/system.py", line 93, in action_create
raise Fail("Applying %s failed, parent directory %s doesn’t exist" % (self.resource, dirname))
Fail: Applying File failed, parent directory /etc/hadoop/conf doesn’t exist
Error: Error: Unable to run the custom hook script
2015-03-11 09;t exist" % (self;lib/: False}
2015-03-11 09;ignore_failures’lib/lib/, ’INFO’我也遇到了类似问题,不知道怎么解决,你的解决了吗;usr//etc/hadoop/.6/?我的错如下;ANY’: Error: Unable to run the custom hook script [’/Applying %s failed, parent directory %s doesn’.py"script/script;lib/, ’//var/lib/ambari-agent/,586 - Group[’nobody’var/environment;ambari-agent/data/tmp’

linux中安装了一个插件,这个插件装完后正常的情况在终端输入./phpxujh -p pid可查看当前PID的运行情况,

目录
开始之前
系统环境
监控内容
所需软件包
CentOS7重要变化
配置开发环境
同步时间
关闭Selinux
使用CRT上传软件包
安装邮件服务
监控主机安装
常用到的命令
安装nagios所需要的运行环境
增加用户
安装nagios
配置权限
安装插件
安装nrpe
远程主机安装
常用到的命令
配置运行环境
安装nagios-plugin
安装nrpe
启动nrpe
监控主机安装PNP
配置开发环境
安装pnp4nagios (版本号为0.6)
配置pnp4nagios
图表展示
问题集合
在首次配置了nagios监控端后,在浏览器输入地址后连接不上
启动nrpe后却不能互相通信
安装pnp4nagios后出现The requested URL /pnp4nagios/graph was not found on this server.
出现“CHECK_NRPE: Error - Could not complete SSL handshake.”的错误
执行 ./configure时报错:configure error cannot find ssl headers
解压./configure 后,在nagios-4.0.8进行make all报错
安装nrpe时执行.configure出错
错误:perfdata directory "/usr/local/pnp4nagios/var/perfdata/" is empty
开始之前
声明:本文中的命令都经过了测试,但难免有所纰漏,如果你发现命令粘贴后运行有错,可能是由于符号的格式(尤其是破折号)导致的,此时你应该自己手打一遍命令。对于本文中发现的错误和建议,请发送邮件给我:
kylinlingh@foxmail.com,请在邮件主题里注明“关于nagios的问题(建议)”。
--------------------------------------分割线 --------------------------------------
***隐藏网址***
***隐藏网址***
***隐藏网址***
***隐藏网址***
***隐藏网址***
***隐藏网址***
***隐藏网址***
***隐藏网址***
***隐藏网址***
--------------------------------------分割线 --------------------------------------
系统环境
一共3台机器,全都按照CentOS7最小化模式安装系统
系统版本号
# cat /etc/RedHat-release
CentOS Linux release 7.0.1406 (Core)
监控主机
(一台)
IP地址:192.168.1.204
主机名称:nagios_server_204
远程主机
(两台)
IP地址:192.168.1.112
主机名称:nagios_slave_112
IP地址:192.168.1.113
主机名称:nagios_slave_113
分区情况
安装时使用默认分区(使用 df 命令来查看)
# df -h
监控内容
要监控的服务
监控命令
cpu负载
(check_linux_state.pl -C)
当前用户登录数量
(check_users)
磁盘使用情况
(check_disk)
总进程数
(check_procs)
内存使用情况
(check_linux_stats.pl -M)
负载均衡
(check_load)
磁盘IO
(check_linux_stats.pl -I)
网络流量
(check_linux_stats.pl -N)
打开的文件数量
(check_linux_stats.pl -F)
socket连接数
(check_linux_stats.pl -S)
进程使用的内存和CPU
(check_linux_stats.pl -T)
指定的网站是否可连接
***隐藏网址***
系统在线时长
(check_uptime)
所需软件包
监控主机
软件包
下载地址
nagios-4.0.8.tar.gz
请到我的github地址里下载:
***隐藏网址***
注明:我的github项目install_nagios_automatically是一个一键自动化安装nagios的项目(能运行,但还在完善中)
nagios-plugins-2.0.3.tar.gz
nrpe-2.15.tar.gz
pnp4nagios-0.6.25.tar.gz
Sys-Statistics-Linux-0.66.tar.gz
libxml2-2.7.1.tar.gz
远程主机
软件包
下载地址
nagios-plugins-2.0.3.tar.gz
请到我的github地址里下载:
***隐藏网址***
nrpe-2.15.tar.gz
Sys-Statistics-Linux-0.66.tar.gz
Centos7重要变化
Centos7相比较以前的Centos有一些涉及到常用命令的变化,如果不事先了解,会在使用命令的时候造成巨大的困扰
Centos7默认没有ifconfig和netstat两个命令了,ip addr命令代替了ifconfig,只要安装上net-tools包就可以继续使用ifconfig和netstat两个命令了
***隐藏网址***
job
以前的系统
CentOS7
服务开机启动
***隐藏网址***
***隐藏网址***
服务不开机启动
***隐藏网址***
***隐藏网址***
服务状态
***隐藏网址***
***隐藏网址***
所有服务的启动状态
chkconfig --list
systemctl
启动服务
***隐藏网址***
***隐藏网址***
停止服务
***隐藏网址***
***隐藏网址***
重启服务
***隐藏网址***
***隐藏网址***
配置开发环境
同步时间
把监控系统里的所有机器都同步一次网络时间(非常重要)
timedatectl #该命令用来检查当前时间和时区
如果发现所有机器的时区不一致,此时就要使用命令
timedatectl list-timezones #该命令列出了所有的时区
timedatectl set-timezone Asia/Shanghai #该命令把时区设置为上海
ntpdate time.nist.gov #该命令同步网络当前的时间
如果提示没有ntpdate命令,则安装ntp,并且配置系统自动更新时间
# yum install ntp -y
# /usr/sbin/ntpdate time.nist.gov
# echo ’#time sync’》》/var/spool/cron/root
# echo ’*/10**** /usr/sbin/ntpdate time.nist.gov 》/dev/null 2》&1’》》/var/spool/cron/root
关闭Selinux
不关闭selinux可能会导致一些难以察觉的错误,为了保险起见,首先关闭selinux:
vi /etc/selinux/config
重启机器
检查selinux是否关闭:
getenforce #如果显示enforcing则没有关闭
使用SecureCRT上传软件包
我在这里使用的SSH连接工具是SecureCRT7.2,通过这个工具上传文件到Linux的步骤如下:
1. 首先在Linux中安装传送文件命令:
yum install lrzsz -y
2. 然后在Linux中跳转到/usr/local/src目录下
cd /usr/local/src
3. 运行CRT的传送文件命令
安装邮件服务
因为邮件报警服务需要安装mail功能
yum install –y mailx
yum install –y sendmail
systemctl restart sendmail.service
mail –s Test xxx@xxx.com(你的邮箱地址)
#此时进入输入模式,输入完邮件内容后按ctrl + d退出并且发送
监控主机安装
常用到的命令
命令内容
命令格式
检查nagios的配置文件是否有错
/etc/init.d/nagios checkconfig
或者
/usr/local/nagios/bin/nagios -v /usr/local/nagios/etc/nagios.cfg
启动nagios
systemctl start nagios.service
或者
/usr/local/nagios/bin/nagios -d /usr/local/nagios/etc/nagios.cfg
修改了nagios的配置文件后重新加载配置文件
/etc/init
安装nagios所需要的运行环境
# yum install gcc glibc glibc-common -y
# yum install php php-gd perl -y
***隐藏网址***
***隐藏网址***
增加用户
useradd -m nagios
并将nagios以及apache用户加入到nagcmd组中
groupadd nagcmd
usermod -G nagcmd nagios
usermod -a -G nagcmd apache #把apace用户添加到与nagios的一个组(apache用户会在安装apache时自动创建)
安装nagios
# tar -zxvf nagios-4.0.8.tar.gz
# cd nagios-4.0.8
首先初始化和建立编译的环境
#./configure --with-command-group=nagcmd
如果能看到下面的基本配置信息则说明初始的环境已经成功配置完成:
之后按照提示执行命令来进行编译:
# make all
# make install
# make install-init
# make install-config
# make install-commandmode
# make install-webconf
安装完成之后,在/usr/local/nagios目录下如果能够看到这些目录:
就表示Naigos安装成功了。
Nagios的样例配置文件默认安装在/usr/local/nagios/etc目录下,配置这些文件就可以使得nagios按要求运行(详细的配置过程请参考我的另一篇博文:nagios服务配置详解)
此时应该为email指定您想用来接收nagios警告信息的邮件地址,默认是本机的nagios用户:
# vi /usr/local/nagios/etc/objects/contacts.cfg
email nagios@localhost #把描红的地方修改为你的email地址
创建一个登录nagios web程序的用户(用户名配置为nagiosadmin则不需要配置权限,设置为其他用户名就要配置权限),我在这里把用户名设置为kylinlin,密码为123456,这个用户帐号在以后通过web登录nagios认证时所用:
# htpasswd -bc /usr/local/nagios/etc/htpasswd.users kylinlin 123456 #把描红的地方修改为你的用户名和密码
配置权限
如果在上面创建登陆nagios web程序的用户名不是nagiosadmin(我在上面已经设置为kylinlin),在登陆nagios的web界面后(此时我们还不能登录,但如果你忽略了这一小节的配置,那么在后面的登陆中就会看到如下的界面),点击Hosts或Services会显示图片红色的错误提示
是因为nagios默认把全部的权限给nagiosadmin,所以可以通过修改cgi.cfg文件赋予kylinlin权限,切换到/usr/local/nagios/etc目录下
# sed -i ’s#nagiosadmin#kylinlin#g’ cgi.cfg #这条命令将nagiosadmin用户名替换为kylinlin
# grep kylinlin cgi.cfg #这条命令检查是否修改成功
***隐藏网址***
***隐藏网址***
检查其主配置文件的语法是否正确:
# /usr/local/nagios/bin/nagios -v /usr/local/nagios/etc/nagios.cfg
或者使用下面这个命令来检查语法
# /etc/init.d/nagios checkconfig
显示错误数为0才正确
配置成功
安装插件
刚才已经提到Nagios主程序只是一个控制中心,而能够起到服务监测和系统监测等功能的是众多Nagios的插件,没有插件的Nagios系统其实只是一个空壳。因此在安装了Nagios平台之后我们还需要安装插件。
Nagios插件同样是在其官方网站下载,目前版本是1.4.15。我将下载的源码包放到/usr/local目录下,按照下面的步骤进行解压,编译和安装:
# tar zxf nagios-plugins-2.0.3.tar.gz
# cd nagios-plugins-2.0.3
# ./configure --with-nagios-user=nagios --with-nagios-group=nagios
#make
#make install
通过下面的命令查看安装了多少个插件
#ls /usr/local/nagios/libexec/|wc -l
然后把Nagios加入到服务列表中以使之在系统启动时自动启动:
# chkconfig --add nagios
# chkconfig nagios on
执行下面的命令来验证Nagios的样例配置文件:
# /usr/local/nagios/bin/nagios -v /usr/local/nagios/etc/nagios.cfg

如何解决nagios core not running

nagios运行
# ps -ef|grep nagios|grep -v grep
***隐藏网址***
***隐藏网址***
***隐藏网址***
***隐藏网址***
nagios 21929 1 0 09:50 ? 00:00:00 /usr/local/nagios/bin/nagios -d /usr/local/nagios/etc/nagios.cfg
nagios 21931 21929 0 09:50 ? 00:00:00 /usr/local/nagios/bin/nagios --worker /usr/local/nagios/var/rw/nagios.qh
nagios 21932 21929 0 09:50 ? 00:00:00 /usr/local/nagios/bin/nagios --worker /usr/local/nagios/var/rw/nagios.qh
.............
nagios 21976 21929 0 09:50 ? 00:00:00 /usr/local/nagios/bin/nagios --worker /usr/local/nagios/var/rw/nagios.qh
nagios 21977 21929 0 09:50 ? 00:00:00 /usr/local/nagios/bin/nagios --worker /usr/local/nagios/var/rw/nagios.qh
nagios 21978 21929 0 09:50 ? 00:00:00 /usr/local/nagios/bin/nagios --worker /usr/local/nagios/var/rw/nagios.qh
nagios 21979 21929 0 09:50 ? 00:00:00 /usr/local/nagios/bin/nagios -d /usr/local/nagios/etc/nagios.cfg

关于nagios core和Linux里面自动化部署工具有哪些的介绍到此就结束了,不知道你从中找到你需要的信息了吗 ?如果你还想了解更多这方面的信息,记得收藏关注本站。

nagios core(Linux里面自动化部署工具有哪些)

本文编辑:admin

更多文章:


form表单制作(为什么制作的form表单会在网页显示中多出一行)

form表单制作(为什么制作的form表单会在网页显示中多出一行)

大家好,如果您还对form表单制作不太了解,没有关系,今天就由本站为大家分享form表单制作的知识,包括为什么制作的form表单会在网页显示中多出一行的问题都会给大家分析到,还望可以解决大家的问题,下面我们就开始吧!

2026年10月11日 09:10

teammate(teammate,company,partner)

teammate(teammate,company,partner)

各位老铁们,大家好,今天由我来为大家分享teammate,以及teammate,company,partner的相关问题知识,希望对大家有所帮助。如果可以帮助到大家,还望关注收藏下本站,您的支持是我们最大的动力,谢谢大家了哈,下面我们开始吧

2026年10月11日 06:10

javascript arraybuffer(javascript可以把base64编码转换成二进制代码吗求示例代码!)

javascript arraybuffer(javascript可以把base64编码转换成二进制代码吗求示例代码!)

其实javascript arraybuffer的问题并不复杂,但是又很多的朋友都不太了解javascript可以把base64编码转换成二进制代码吗求示例代码!,因此呢,今天小编就来为大家分享javascript arraybuffer的

2026年10月11日 04:00

text函数公式(excel中round和text函数的区别是什么)

text函数公式(excel中round和text函数的区别是什么)

“text函数公式”相关信息最新大全有哪些,这是大家都非常关心的,接下来就一起看看text函数公式(excel中round和text函数的区别是什么)!

2026年10月11日 03:50

pascal编程软件(介绍一下pascal语言!)

pascal编程软件(介绍一下pascal语言!)

大家好,如果您还对pascal编程软件不太了解,没有关系,今天就由本站为大家分享pascal编程软件的知识,包括介绍一下pascal语言!的问题都会给大家分析到,还望可以解决大家的问题,下面我们就开始吧!

2026年10月11日 02:40

google chrome打不开(chrome浏览器打不开怎么回事 浏览器打不开的处理方法)

google chrome打不开(chrome浏览器打不开怎么回事 浏览器打不开的处理方法)

本篇文章给大家谈谈google chrome打不开,以及chrome浏览器打不开怎么回事 浏览器打不开的处理方法对应的知识点,文章可能有点长,但是希望大家可以阅读完,增长自己的知识,最重要的是希望对各位有所帮助,可以解决了您的问题,不要忘了

2026年10月11日 02:00

websocket整合springboot(Springboot整合Websocket遇到的坑)

websocket整合springboot(Springboot整合Websocket遇到的坑)

大家好,websocket整合springboot相信很多的网友都不是很明白,包括Springboot整合Websocket遇到的坑也是一样,不过没有关系,接下来就来为大家分享关于websocket整合springboot和Springbo

2026年10月11日 01:40

小米官方首爆miui14(miui14耗电严重官方回应)

小米官方首爆miui14(miui14耗电严重官方回应)

各位老铁们好,相信很多人对小米官方首爆miui14都不是特别的了解,因此呢,今天就来为大家分享下关于小米官方首爆miui14以及miui14耗电严重官方回应的问题知识,还望可以帮助大家,解决大家的一些困惑,下面一起来看看吧!

2026年10月11日 00:40

drawerlayout(android 怎样让drawerlayout设置的侧滑菜单的内容充满屏幕)

drawerlayout(android 怎样让drawerlayout设置的侧滑菜单的内容充满屏幕)

本篇文章给大家谈谈drawerlayout,以及android 怎样让drawerlayout设置的侧滑菜单的内容充满屏幕对应的知识点,希望对各位有所帮助,不要忘了收藏本站喔。

2026年10月10日 19:20

xor四位数怎么运算(单片机怎样用C语言实现4个数字间的异或)

xor四位数怎么运算(单片机怎样用C语言实现4个数字间的异或)

大家好,今天小编来为大家解答以下的问题,关于xor四位数怎么运算,单片机怎样用C语言实现4个数字间的异或这个很多人还不知道,现在让我们一起来看看吧!

2026年10月10日 17:50

最近更新

热门文章

打印机m7400(m7400打印机清零方法)
2026-08-29 07:50:01 浏览:5
acrobat各版本区别(Acrobat XI Pro与 Acrobat PRO DC什么区别)
2026-08-29 22:30:20 浏览:2
联想y510p怎么升级(联想y510p换cpu)
2026-08-17 03:30:04 浏览:2
标签列表